Вы здесь

не обновляется релиз на 2.0.48.6

В бухгалтерии не обновляется релиз на 2.0.48.6, при обновлении видно, что идет попытка реструктуризации Регистра сведений "Адресный классификатор" и зависает на несколько суток.
При попытке очистить ее из 1С с помощью кода или обработки:
Набор = РегистрыСведений.АдресныйКлассификатор.СоздатьНаборЗаписей();
Набор.Записать(Истина);
Результат тот же самый.
В этой таблице 3 175 223 записей.
Используя библиотеку 1CDLib, получаем прямой доступ к этой таблице и очищаем ее
ИмяТаблицы = "_InfoRg7594";
FileDB.OpenTable(0, ИмяТаблицы);
FileDB.MoveFirstRecord(0);
Н = 0;
Если FileDB.OpenTable(0, ИмяТаблицы) Тогда
ОбработкаПрерыванияПользователя();
сообщить(FileDB.GetTableRecordsCount(0));
FileDB.MoveFirstRecord(0);
Пока FileDB.MoveNextRecord(0) Цикл
Н = Н + 1;
Если Н % 10000 = 0 Тогда
состояние(Н);
КонецЕсли;
FileDB.DeleteRecord(0);
КонецЦикла;
FileDB.CloseTable(0);
Иначе
сообщить("Не получилось открыть таблицу: "+ИмяТаблицы);
КонецЕсли;

Яндекс.Метрика